GeoServer之開源專案JAI-EXT存在高風險安全漏洞(CVE-2022-24816),請儘速確認並進行修補

內容說明:

研究人員發現在GeoServer之開源專案JAI-EXT中,其jt-jiffle套件存在程式碼注入(Code Injection)漏洞(CVE-2022-24816),未經身分鑑別之遠端攻擊者可利用此漏洞遠端執行任意程式碼。該漏洞已遭駭客利用,請儘速確認並進行修補。

影響平台:

jt-jiffle套件1.1.22(不含)以前版本

處置建議:

官方已針對漏洞釋出修復更新,請參考官方說明進行更新,網址如下:
https://github.com/geosolutions-it/jai-ext/security/advisories/GHSA-v92f-jx6p-73rx

參考資料:

  1. https://nvd.nist.gov/vuln/detail/CVE-2022-24816
  2. https://github.com/geosolutions-it/jai-ext/security/advisories/GHSA-v92f-jx6p-73rx
  3. https://github.com/geosolutions-it/jai-ext/commit/cb1d6565d38954676b0a366da4f965fef38da1cb